使用MAVEN请注意,MAVEN不支持最新版jdk1.7

最新说明:MAVEN对1.7的支持没问题,但是如果你遇到和jdk有关的莫名其妙的问题,可以尝试换个版本试试。


MAVEN官网最新版本的系统要求


System Requirements

JDKMaven 3.2 requires JDK 1.6 or above, while Maven 3.0/3.1 requires JDK 1.5 or above (this is to execute Maven - it still allows you to build against 1.3 and prior JDK's)
MemoryNo minimum requirement
DiskNo minimum requirement. Approximately 100MB will be used for your local repository, however this will vary depending on usage and can be removed and redownloaded at any time.
Operating SystemNo minimum requirement. On Windows, Windows NT and above or Cygwin is required for the startup scripts. Tested on Windows XP, Fedora Core and Mac OS X.


系统要求jdk1.6或以上,但是我最近电脑重装系统之后,不想安装太多版本jdk,所以就安装了1.7的最新版。

没想到使用MAVEN的时候,总是无法下载插件,无法联网,就算增加源也解决不了问题,很费解。在Google上查询结果后也没有找到解决办法。


MAVEN错误信息如下:

Downloading: http://maven.oschina.net/content/groups/public/org/apache/maven/plugins/maven-install-plugin/2.4/maven-install-plugin-2.4.pom
三月 06, 2014 8:40:45 下午 org.apache.maven.wagon.providers.http.httpclient.impl.execchain.RetryExec execute
信息: I/O exception (java.net.SocketException) caught when processing request: Connection reset
三月 06, 2014 8:40:45 下午 org.apache.maven.wagon.providers.http.httpclient.impl.execchain.RetryExec execute
信息: Retrying request
三月 06, 2014 8:41:27 下午 org.apache.maven.wagon.providers.http.httpclient.impl.execchain.RetryExec execute
信息: I/O exception (java.net.SocketException) caught when processing request: Connection reset
三月 06, 2014 8:41:27 下午 org.apache.maven.wagon.providers.http.httpclient.impl.execchain.RetryExec execute
信息: Retrying request
三月 06, 2014 8:42:09 下午 org.apache.maven.wagon.providers.http.httpclient.impl.execchain.RetryExec execute
信息: I/O exception (java.net.SocketException) caught when processing request: Connection reset
三月 06, 2014 8:42:09 下午 org.apache.maven.wagon.providers.http.httpclient.impl.execchain.RetryExec execute
信息: Retrying request


[ERROR] Plugin org.apache.maven.plugins:maven-install-plugin:2.4 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.ap
ache.maven.plugins:maven-install-plugin:jar:2.4: Could not transfer artifact org.apache.maven.plugins:maven-install-plugin:pom:2.4 from/to nexus-osc (http://maven.oschina.net/content/groups/public/): Connection reset -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException


从错误信息来看,只能从java.net.SocketException入手,因为我其他电脑上的jdk都是1.6,1.7同时存在,而且JAVA_HOME都配置的1.6,所以觉得可能是这方面的问题。

没有换JDK之前:

D:\Git>mvn -v
Apache Maven 3.2.1 (ea8b2b07643dbb1b84b6d16e1f08391b666bc1e9; 2014-02-15T01:37:52+08:00)
Maven home: C:\Program Files\apache-maven
Java version: 1.7.0_45, vendor: Oracle Corporation
Java home: C:\Program Files\Java\jdk1.7.0_45\jre
Default locale: zh_CN, platform encoding: GBK
OS name: "windows 7", version: "6.1", arch: "amd64", family: "windows"


换了JDK之后:

D:\Git>mvn -v
Apache Maven 3.2.1 (ea8b2b07643dbb1b84b6d16e1f08391b666bc1e9; 2014-02-15T01:37:52+08:00)
Maven home: C:\Program Files\apache-maven
Java version: 1.6.0_43, vendor: Sun Microsystems Inc.
Java home: C:\Program Files\Java\jdk1.6.0_43\jre
Default locale: zh_CN, platform encoding: GBK
OS name: "windows 7", version: "6.1", arch: "amd64", family: "windows"


再之后,运行MAVEN就没有问题了。


如果有人遇到类似的问题,可以换个低版本的JDK试试。我电脑安装的都是64位版本,32位没有测试是否有问题。


使用IDEA或Eclipse的还需要在IDE中对MAVEN的jdk进行修改。已知IDEA需要修改两处。Eclipse暂时没试,估计不用改。


解决问题的方法确实简单,不过由于过于相信MAVEN官方说明,因而没考虑到JDK版本的问题,实在是浪费时间。

isea533 CSDN认证博客专家 运维开发 系统架构
《MyBatis从入门到精通》作者,MyBatis分页插件PageHelper作者,通用Mapper作者,个人网站:https://mybatis.io
已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 酷酷鲨 设计师:CSDN官方博客 返回首页